CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Nov 18, 2019 - 13:16 PST
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Nov 18, 2019 - 07:27 PST
This incident affected: California St. Branch (California CoinStar).