CoinStar (Stonestown) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Sep 14, 2020 - 09:57 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 01, 2020 - 13:06 PDT
Investigating
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Aug 25, 2020 - 07:49 PDT
This incident affected: Stonestown Branch (CoinStar).