Online & Mobile Banking Response Time
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 29 days ago. Mar 22, 2019 - 12:30 PDT
Monitoring
We have identified the issue and put a temporary fix in place. We are continuing to work to apply a permanent solution. Thank you for your patience.
Posted 29 days ago. Mar 22, 2019 - 11:11 PDT
Investigating
We are investigating an issue with the response time of our Online & Mobile Banking platform. Some services may be intermittently affected, and we will provide updates as soon as possible. We apologize for any inconvenience.
Posted 30 days ago. Mar 22, 2019 - 09:53 PDT
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).