The Coinstar machine at our California Branch is currently unavailable and undergoing maintenance
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 17, 2019 - 14:52 PST
Investigating
We are currently investigating this issue.
Posted Jan 16, 2019 - 11:41 PST
This incident affected: California St. Branch (California CoinStar).