CoinStar (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 13 days ago. Jun 03, 2019 - 08:01 PDT
Identified
The CoinStar machine at our Mint Plaza branch is unavailable at this time. We apologize for the inconvenience.
Posted 18 days ago. May 29, 2019 - 18:08 PDT
This incident affected: Mint Plaza Branch (CoinStar).