CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Dec 31, 2019 - 14:04 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 31, 2019 - 14:03 PST
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Dec 24, 2019 - 08:02 PST
This incident affected: California St. Branch (CoinStar).