Instant Issue Cards Unavailble
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Dec 26, 2019 - 14:30 PST
Update
We are continuing to investigate this issue.
Posted Dec 26, 2019 - 13:43 PST
Investigating
We are currently unable to print instant issue cards. We are currently investigating this issue.
Posted Dec 26, 2019 - 13:43 PST
This incident affected: Debit & Credit Cards (Orders & Reissues).