Mint Plaza ATM out of service
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 04, 2019 - 10:34 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 8 months ago. Jan 02, 2019 - 10:42 PST
Update
We are continuing to monitor for any further issues.
Posted 8 months ago. Jan 02, 2019 - 10:42 PST
Monitoring
The ATM at Mint Plaza is currently out of order.
Posted 8 months ago. Jan 02, 2019 - 09:31 PST
This incident affected: Mint Plaza Branch (ATM).