CoinStar (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 14:48 PDT
Monitoring
The CoinStar machine at our Mint Plaza branch is unavailable at this time. We apologize for the inconvenience.
Posted Mar 19, 2020 - 10:36 PDT
This incident affected: Mint Plaza Branch (ATM, CoinStar).