Online & Mobile Banking Response Time
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Nov 25, 2019 - 18:47 PST
Update
We are continuing to investigate this issue.
Posted Nov 25, 2019 - 18:46 PST
Update
We are continuing to investigate this issue.
Posted Nov 25, 2019 - 10:45 PST
Investigating
We are investigating an issue with the response time of our Online & Mobile Banking platform. Some services may be intermittently affected, and we will provide updates as soon as possible. We apologize for any inconvenience.
Posted Nov 25, 2019 - 10:45 PST
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).