Online & Mobile Banking Response Time
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 09:33 PST
Monitoring
Due to increased traffic to our site, new transactions may take longer to appear within Online/Mobile Banking. If you do not see a new or recent transaction listed online banking, please check again later in the day. We apologize for any inconvenience and thank you for your patience.
Posted Jan 05, 2021 - 08:36 PST
This incident affected: Online Services (Online Banking (Web), Mobile Banking).