CoinStar (Stonestown) Service Alert

Incident Report for SF Fire Credit Union

Resolved

The CoinStar machine is back in service. We thank you for your patience.
Posted Nov 18, 2019 - 16:01 PST

Investigating

The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Nov 16, 2019 - 11:11 PST
This incident affected: Stonestown Branch (Stonestown CoinStar).