Online Loan Applications Unavailable
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Apr 26, 2022 - 08:53 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 25, 2022 - 14:02 PDT
Investigating
Our online loan applications system is currently unavailable. We are working to correct the issue and apologize for the inconvenience. If you need assistance with a loan request, please reach out to our Contact Center.
Posted Apr 25, 2022 - 13:51 PDT
This incident affected: Online Services (Online & Mobile Banking).