Travel Notifications Outgage Detected
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 11:39 PDT
Update
We are continuing to investigate this issue.
Posted Apr 23, 2024 - 11:24 PDT
Investigating
We are investigating an issue with Travel Notifications. It is currently unavailable. Please use the Message Center to provide us with the dates and location of your upcoming travel. Thank you for your patience while we work to resolve this issue.
Posted Apr 23, 2024 - 11:11 PDT
This incident affected: Online Services (Card Management (Card Activation, Travel Notifications, PIN changes)).