Online Banking Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 17:08 PST
Investigating
We are investigating an outage with our Online & Mobile Banking platform, and will provide updates as soon as possible. We apologize for any inconvenience.
Posted Mar 01, 2021 - 15:00 PST
This incident affected: Online Services (Online & Mobile Banking, Money Movement).