CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 14:25 PDT
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Sep 14, 2020 - 09:51 PDT
This incident affected: California St. Branch (CoinStar).