Mobile Deposit Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Oct 25, 2023 - 14:02 PDT
Investigating
We are currently experiencing service issues with our Mobile Deposit feature. During this time you may experience slowness in depositing checks or the overall service being unavailable. We apologize for the inconvenience.
Posted Oct 25, 2023 - 11:51 PDT
This incident affected: Online Services (Mobile Deposit).