CoinStar service alert
Incident Report for SF Fire Credit Union
Resolved
Our Coinstar is now operational.
Posted 5 months ago. Jan 09, 2019 - 15:47 PST
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. Jan 04, 2019 - 10:04 PST
Identified
The CoinStar machine is unavailable at this time.
Posted 5 months ago. Jan 04, 2019 - 10:02 PST
This incident affected: Stonestown Branch (CoinStar).