We are unable to issue instant debit/credit cards currently
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 24, 2019 - 13:38 PDT
Monitoring
We are currently unable to issue instant debit/credit cards as our printer is undergoing maintenance. We will update the status when we are able to issue cards again.
Posted 2 months ago. Jul 24, 2019 - 13:16 PDT
This incident affected: Debit & Credit Cards (Orders & Reissues).