Online Banking Experiencing Degradation to Services
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 16 days ago. May 06, 2019 - 16:01 PDT
Update
We are continuing to work on a fix for this issue.
Posted 16 days ago. May 06, 2019 - 16:01 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 16 days ago. May 06, 2019 - 15:57 PDT
This incident affected: Online Services (Online Banking (Web)).