Online Chat Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted May 30, 2024 - 09:43 PDT
Investigating
Our chat support is temporarily unavailable due to a system outage. Please call or send us a message using the message center with any assistance you need. We apologize for the inconvenience and are working to restore services as soon as possible.
Posted May 30, 2024 - 09:30 PDT
This incident affected: Contact Center (Phone Support, Web Chat).