We’re pleased to share that the branch has reopened and has resumed normal operations. Thank you for your patience and understanding during the closure.
Posted Jun 20, 2025 - 11:52 PDT
Update
The branch closure has been extended and will remain closed tomorrow, Tuesday, June 17th. We apologize for the continued inconvenience and will provide another update as soon as we have more information.
Posted Jun 16, 2025 - 16:51 PDT
Update
The branch closure has been extended and will remain closed today, Monday, June 16th. We anticipate reopening tomorrow, Tuesday, June 17th, and will share further updates by the end of the day.
Posted Jun 16, 2025 - 08:35 PDT
Update
The Stonestown Branch will also be closed on Saturday, June 14th. We apologize for any inconvenience this may cause.
Posted Jun 13, 2025 - 16:05 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2025 - 15:46 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2025 - 15:46 PDT
Investigating
Due to a plumbing issue, our Stonestown Branch will be temporarily closed. We expect the branch to re-open and resume normal operations on Tuesday, June 17th.
We apologize for any inconvenience this may cause. Please visit our website, sffirecu.org for alternate locations and for updates.
Posted Jun 13, 2025 - 15:42 PDT
This incident affected: Stonestown Branch (Stonestown Branch Lobby).