Online Banking Degradation of Service
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 12 days ago. Sep 11, 2019 - 18:06 PDT
Update
We are continuing to investigate this issue.
Posted 12 days ago. Sep 11, 2019 - 17:01 PDT
Investigating
We are currently investigating this issue.
Posted 12 days ago. Sep 11, 2019 - 16:57 PDT
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).