CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Apr 17, 2020 - 11:59 PDT
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Apr 17, 2020 - 11:58 PDT
This incident affected: California St. Branch (CoinStar).