CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 19 days ago. May 28, 2019 - 15:10 PDT
Update
We are continuing to work on a fix for this issue.
Posted 19 days ago. May 28, 2019 - 11:38 PDT
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted 26 days ago. May 21, 2019 - 15:23 PDT
This incident affected: California St. Branch (CoinStar).