California St. ATM will we out of service 3-4 hours.
Incident Report for SF Fire Credit Union
Resolved
Installation has been rescheduled to tomorrow. ATM is still currently in service.
Posted 4 months ago. Jan 23, 2019 - 10:23 PST
Identified
California St. ATM will be out of service 3-4 hours to finish installation.
Posted 4 months ago. Jan 23, 2019 - 09:06 PST
This incident affected: California St. Branch (ATM).