ATM (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 02, 2019 - 11:25 PDT
Identified
We are currently experiencing an issue with the ATM at our Mint Plaza branch. Access to this ATM may be limited or unavailable at this time. We apologize for the inconvenience.
Posted 3 months ago. Jul 29, 2019 - 10:34 PDT
This incident affected: Mint Plaza Branch (ATM).