CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
The Coinstar issue has been resolved and is fully operational.
Posted 16 days ago. May 06, 2019 - 12:07 PDT
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted 16 days ago. May 06, 2019 - 11:10 PDT
This incident affected: California St. Branch (CoinStar).