Bill Pay Sync Issue
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted May 04, 2020 - 09:31 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2020 - 09:25 PDT
Investigating
We are investigating an issue with our Bill Pay service in Online & Mobile Banking and will provide updates as soon as possible. We apologize for any inconvenience.
Posted May 04, 2020 - 08:01 PDT
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).