Telephone Service Outage
Incident Report for SF Fire Credit Union
Resolved
Good news! Our telephone service has been restored. You can reach us via telephone again. Thank you for your patience.
Posted Apr 22, 2024 - 09:47 PDT
Update
Good news! Our telephone service has been restored. You can reach us via telephone again. Thank you for your patience.
Posted Apr 22, 2024 - 09:20 PDT
Investigating
Our telephone service is temporarily unavailable. If you need to contact us during this time, please click on the bubble "Let's Talk" at the bottom right hand corner of our website, to reach a Representative via our chat service. We apologize for any inconvenience this may cause. Our phone service provider is working to restore this service as soon as possible.
Posted Apr 22, 2024 - 08:23 PDT
This incident affected: Contact Center (Phone Support, Web Chat).