Bill Pay Service Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 09:58 PDT
Monitoring
Currently our Bill Pay Services are unavailable. We are working diligently to restore this service as soon as possible. We apologize for the inconvenience
Posted Oct 30, 2019 - 09:33 PDT
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).