Mobile Deposit Service Alert

Incident Report for SF Fire Credit Union

Resolved

This incident has been resolved.
Posted Aug 19, 2022 - 18:03 PDT

Update

We are continuing to investigate this issue.
Posted Aug 19, 2022 - 18:03 PDT

Update

We are continuing to investigate this issue.
Posted Aug 19, 2022 - 18:02 PDT

Investigating

We are currently experiencing service issues with our Mobile Deposit feature. During this time you may experience slowness in depositing checks or the overall service being unavailable. We apologize or the inconvenience.
Posted Aug 19, 2022 - 16:36 PDT
This incident affected: Online Services (Money Movement).