Instant Issue Machine Maintenance
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 11:43 PDT
Identified
We'll be performing regular system maintenance on our debit/credit card printer. During this time we will be unable to print instant issue debit/credit cards from our California St. location.
Posted Jul 22, 2020 - 09:43 PDT
This incident affected: Debit & Credit Cards (Orders & Reissues).