Main Branch Temporarily Closed

Incident Report for SF Fire Credit Union

Resolved

The temporary closure of our Main Branch has been resolved. The branch will reopen and resume normal business hours on Tuesday, June 30th.

Thank you for your patience.
Posted Jun 29, 2026 - 18:14 PDT

Identified

Due to a power outage, our Main Branch located at 3201 California St., will be temporarily closed. We expect the branch to re-open and resume normal operations on June 30th, 2026.

We apologize for any inconvenience this may cause. Please visit our website or online banking for alternate locations.
Posted Jun 29, 2026 - 15:47 PDT
This incident affected: California St. Branch (California Branch Lobby, California CoinStar, California ATM).