AWS Service Disruption

Incident Report for SF Fire Credit Union

Resolved

This issue has been resolved. Online and mobile banking are now available, and the wires feature has been restored. We appreciate your patience.
Posted Oct 20, 2025 - 16:39 PDT

Identified

We are currently experiencing issues due to an Amazon Web Services (AWS) disruption. Some of our systems including phone, chat, Phoenix, and online/mobile banking, are being impacted by the outage. The wires feature will be temporarily unavailable until the issue is resolved. Thank you for your patience.
Posted Oct 20, 2025 - 10:48 PDT
This incident affected: Online Services (Online & Mobile Banking, Money Movement).