CoinStar (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 9 days ago. Sep 14, 2019 - 08:25 PDT
Investigating
The CoinStar machine at our Mint Plaza branch is unavailable at this time. We apologize for the inconvenience.
Posted 10 days ago. Sep 13, 2019 - 14:16 PDT
This incident affected: Mint Plaza Branch (CoinStar).