Pacifica Branch Power Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 07:36 PDT
Investigating
Our Pacifica Branch is currently unavailable at this time due to a power outage in the area.
Posted Oct 28, 2019 - 08:02 PDT
This incident affected: Pacifica Branch.