CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Feb 18, 2020 - 08:54 PST
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Feb 14, 2020 - 16:25 PST
This incident affected: California St. Branch (CoinStar).