CoinStar (Stonestown) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 09:28 PST
Investigating
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Jan 24, 2020 - 13:00 PST
This incident affected: Stonestown Branch (CoinStar).