Card Management Widget Unavailable

Incident Report for SF Fire Credit Union

Resolved

This incident has been resolved.
Posted Nov 22, 2024 - 16:48 PST

Update

We are continuing to investigate this issue.
Posted Nov 22, 2024 - 16:47 PST

Investigating

The Card Management services such as travel notices, updating PIN, & temporarily blocking/unblocking a card, are temporarily unavailable. We appreciate your patience as we work to resolve this matter.
Posted Nov 22, 2024 - 10:27 PST
This incident affected: Online Services (Card Management (Card Activation, Travel Notifications, PIN changes)).