CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
The CoinStar machine is back in service. We thank you for your patience.
Posted 4 months ago. Jul 03, 2019 - 11:46 PDT
Investigating
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted 4 months ago. Jul 03, 2019 - 11:34 PDT
This incident affected: California St. Branch (CoinStar).