Online Banking Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 13:00 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2021 - 12:53 PST
Investigating
We are investigating an outage with our Online & Mobile Banking platform, and will provide updates as soon as possible. We apologize for any inconvenience.
Posted Mar 09, 2021 - 12:38 PST
This incident affected: Online Services (Online Banking (Web), Mobile Banking).