Online Banking Outage

Incident Report for SF Fire Credit Union

Resolved

This incident has been resolved.
Posted Feb 21, 2025 - 11:46 PST

Investigating

Online and Mobile Banking services are currently unavailable. We are actively working to resolve the issue and will share updates as soon as possible. We apologize for any inconvenience.
Posted Feb 21, 2025 - 10:27 PST
This incident affected: Online Services (Online & Mobile Banking, Money Movement).