California St branch ATM and Coinstar unavailable
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 13:25 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2020 - 12:47 PDT
Identified
Due to a power outage the ATM and Coinstar machines at the California Street branch are temporarily unavailable
Posted Jul 16, 2020 - 12:46 PDT
This incident affected: California St. Branch (California CoinStar, California ATM).