Online Banking Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Sep 28, 2023 - 09:04 PDT
Identified
We have identified an issue that is currently impacting Mobile App logins on Android devices. We apologize for any inconvenience this may cause and we are actively working to resolve this issue. We thank you for your patience.
Posted Sep 15, 2023 - 13:52 PDT
This incident affected: Online Services (Online & Mobile Banking).