CoinStar (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 3 days ago. Jun 13, 2019 - 13:14 PDT
Investigating
The CoinStar machine at our Mint Plaza branch is unavailable at this time. We apologize for the inconvenience.
Posted 9 days ago. Jun 07, 2019 - 16:50 PDT
This incident affected: Mint Plaza Branch (CoinStar).